Ecoboost power

Discussion in 'Mustang EcoBoost Discussions' started by toyktdlgh, Jun 2, 2017.

  1. Jun 2, 2017 #1
    toyktdlgh

    toyktdlgh Ecoboost Noob

    Joined:
    Jun 1, 2017
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Cincinnati
    Ratings:
    +1 / 0
    I've had my 2016 ecoboost for almost a year now. When i first bought it i had issues with how the power came on when pulling from a start etc. Had the car about 3 months and it spun a rod bearing. She was under warrantee and the entire motor was replaced because metal had made its way up into the cam journals. The second motor had a different feel to it. It was running faster for sure. It was a different car all together. One thing that i cant get over though is the car seems to be sporadic as to how the power comes on. Im not sure if its due to being an automatic or if a little of it is in my head. If i'm in sport mode and punch it 7 out of 10 times it lights up like a Christmas tree and is gone. The other 3 times its kind of thinking about going but isn't sure it wants to. I know the power band is higher on this car so i don't get a smooth onset of it. I was just wondering if this is a turbo thing or if something isn't quite right with this thing. Ill admit this is my first turbo. Im used to Japanese NA cars that like to rev but not this thing. Its different and acts totally different.

    Just as a side note i had another freak thing happen to me in it yesterday on my way home from work. I was in the high speed lane and there was someone doing 45 in a 65. I kind of got on them a bit to move over but they were on their phone and didn't see me pushing them. I floored it around them and the car took off as usual. The next time i hit the gas the car shuddered horribly. It was like i had a flat tire or was about to run out of gas. it shook every time i would hit the gas but stopped when i coasted. i shifted between drive and sport with no change. I finally made my exit and hit a stop sign at the end of the ramp. the engine light flashed a few times then went out. The car hasn't done it since. Any ideas what the heck that could have been? Im not used to something so severe like that happening and it just goes away. The car has an appointment next Thursday at Ford for this anomaly and my broken backup camera. Im worried it wont do it for them and the car is about 1,000 miles out to 30,000 miles, so i'm almost out of my full warrantee. Would be very unhappy if it finally breaks afterwards. To date, under warrantee, I've replaced both front fog lights due to broken seals, the entire motor due to the spun rod, the backup camera has broken, the Sync 3 constantly drops my phone and now this strange shuddering issue. Is this like the most screwed up car or is this just the usual crap? I'm hoping this last trip to the doctor will get things sorted out. If not i may be trading her in sooner than i want to.

    [​IMG]
     
  2. Jun 3, 2017 #2
    Horcy1

    Horcy1 Ecoboost Member

    Joined:
    Mar 24, 2017
    Messages:
    41
    Likes Received:
    10
    Trophy Points:
    8
    Location:
    AUSTRALIA
    Ratings:
    +10 / 0
    There should be a code logged if the engine management light come on. Take it to the dealers and ask them to read the code/s
     
  3. Jun 3, 2017 #3
    Squid

    Squid Moderator Staff Member

    Top Poster Of Month

    Joined:
    Nov 25, 2014
    Messages:
    2,991
    Likes Received:
    862
    Trophy Points:
    113
    Location:
    D/FW area - Texas
    Ratings:
    +1,182 / 2
    It's going to be hard for the dealer to replicate if it's not happened again. Like @Horcy1 said, take it in and let the dealer read the PCM, there should be codes stored in it that might tell them/you what happened. Also, the driveline/power train warranty doesn't go away after 36k, just the cosmetics. Best to ask the dealer. Gads, that shuddering issue sounds like the problem we had with our 13 Focus (automatic) -- there were multiple issues on that and Ford extended the trans warranty out to 100k for it.

    Not the usual for the Mustang. Most of us have really reliable and well built cars. I hope that you get yours sorted.
     
  4. Jun 14, 2017 #4
    toyktdlgh

    toyktdlgh Ecoboost Noob

    Joined:
    Jun 1, 2017
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    Cincinnati
    Ratings:
    +1 / 0
    Thanks!
    Back from the dealer and they found no issues with it at all. Car hasn't done it since and she didn't store a code. Dealer documented the issues and told me they would fix it if it happened again and they could find it. Backup camera is now fine as well. Love it when things like this happen. Hoping it continues to work fine from here on out.
     
    • Like Like x 1
  5. Jun 18, 2017 at 8:02 AM #5
    richter111

    richter111 Ecoboost Member

    Joined:
    May 2, 2017
    Messages:
    57
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    Eagan MN
    Ratings:
    +28 / 0
    Hope for the best for you, your car is beautiful, and I can't believe it has given you so many issues. Ford is usually pretty spot on in quality.
     

Share This Page