Ford Mustang Ecoboost Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2018 Eco A10 with the performance pack, car was perfectly fine and drove amazing. At 24k miles the trans blew and I had to get a complete rebuild from Ford. After the fix, I noticed on long drives the transmission would shift wild and buck, barely giving response when I push on the throttle. At 26k miles I had a leaking seal so they had to replace that too. Now at 30k miles the trans was still having the same problem, and trans fluid was leaking out. Now it’s at Ford for another fix, Am I the only owner with this problem? Does anyone else have reliability issues with the A10?
 

·
Registered
Joined
·
570 Posts
I have a 2018 Eco A10 with the performance pack, car was perfectly fine and drove amazing. At 24k miles the trans blew and I had to get a complete rebuild from Ford. After the fix, I noticed on long drives the transmission would shift wild and buck, barely giving response when I push on the throttle. At 26k miles I had a leaking seal so they had to replace that too. Now at 30k miles the trans was still having the same problem, and trans fluid was leaking out. Now it’s at Ford for another fix, Am I the only owner with this problem? Does anyone else have reliability issues with the A10?

Nope, I have the A10 in my 17 F150 and my 19 Ecoboost mustang and have not had any issues, owned both since new.
 

·
Registered
Joined
·
615 Posts
No issues with mine. In sport it shifts a bit hard sometimes but that is a function of throttle position (too light) which is my fault. I need to take it out somewhere and do a 3/4 to full throttle run and see what it does, which I expect will be as it should be.
 
1 - 3 of 3 Posts
Top