Ford Mustang Ecoboost Forum banner
41 - 44 of 44 Posts

·
Read Only
Joined
·
282 Posts
but its alright to slowly increase speed in 6th right? I have 3.31 gears, and I am manual, when im passing someone slowly, I will give it some gas, it'll stay below, or get to 0 boost, maybe even like 5boost, but not like flooring the car. haven't had any issues myself. I also never heard of lspi til I owned this car, never owned a turbo before. Lol my other cars, floor it in 6th, it just slowly gets there, hundreds of thousands of miles no booom
Just downshift and don't risk it, are you safe with a few psi? Ya probably, but if the risk is there just downshift. It makes no sense not too, you bought a manual use it!
 

·
Registered
Joined
·
1 Posts
Yes i have had the same problem for a while now. I have a 2019 eco fbo besides (intercooler for whatever reason)on e30 and going through my final tunes with stratified tuning. no hate towards stratified at all they are great at tuning would go back 10/10 times. but i have had the “washers and nuts in tin can” sound where it rattles and grinding sound for a few weeks but it was only at idle or in first gear and once i got above 2k rpm it went away or got really quite. since then it’s gotten a lot worse over this past week and i have not drove it in a day. taking it in soon hopefully it’s a piston ring or something and my engine isn’t blown. also i have had white smoke out the back of my car like an oil leakage. And another unrelated issue is my catless downpipe fumes has burned through a sensor and now my car is telling me to service advanced traction, and a few other codes. I have turned most of them off. Any advice or help at all would help, i just hope to fix these issues and finish up my last tuning. I knew from the start when i was gonna go down this rode of chase 370-400whp on a 4 banger I was gonna have some issues but it’s all apart of the hobby

Mark
 

·
Registered
Joined
·
81 Posts
Yes i have had the same problem for a while now. I have a 2019 eco fbo besides (intercooler for whatever reason)on e30 and going through my final tunes with stratified tuning. no hate towards stratified at all they are great at tuning would go back 10/10 times. but i have had the “washers and nuts in tin can” sound where it rattles and grinding sound for a few weeks but it was only at idle or in first gear and once i got above 2k rpm it went away or got really quite. since then it’s gotten a lot worse over this past week and i have not drove it in a day. taking it in soon hopefully it’s a piston ring or something and my engine isn’t blown. also i have had white smoke out the back of my car like an oil leakage. And another unrelated issue is my catless downpipe fumes has burned through a sensor and now my car is telling me to service advanced traction, and a few other codes. I have turned most of them off. Any advice or help at all would help, i just hope to fix these issues and finish up my last tuning. I knew from the start when i was gonna go down this rode of chase 370-400whp on a 4 banger I was gonna have some issues but it’s all apart of the hobby

Mark
This post is really old....in any case, I'm sorry, but it sounds like you have major engine problems or will be getting a new engine.
 
41 - 44 of 44 Posts
Top