Ford Mustang Ecoboost Forum banner
21 - 27 of 27 Posts

·
Premium Member
Joined
·
1,898 Posts
Does it really prevent lugging? On my base model, A10, geared for economy, I feel like in city driving it sometimes goes too far, too low rpm -- sacrificing the engine for mpg. I couldn't say the exact rpm or situation -- I rarely hammer on it -- but it's just too low and just "doesn't feel right" sometimes. Anyone else notice this? Not sure if it is technically "lugging." I prefer "S" mode in town to keep the rpms up, feels so much better, but also seems more than is necessary to prevent it from happening....
I do the same thing, S mode in town!
 

·
Registered
Joined
·
1,051 Posts
Does it really prevent lugging? On my base model, A10, geared for economy, I feel like in city driving it sometimes goes too far, too low rpm -- sacrificing the engine for mpg. I couldn't say the exact rpm or situation -- I rarely hammer on it -- but it's just too low and just "doesn't feel right" sometimes. Anyone else notice this? Not sure if it is technically "lugging." I prefer "S" mode in town to keep the rpms up, feels so much better, but also seems more than is necessary to prevent it from happening....
Yes, mine will go all the way into 9th as low as 45 mph at light steady throttles, but if I want to accelerate, I slowly roll into the gas until it downshifts to 5th or 6th before I get past half throttle. If I need to accelerate quicker then either use paddles to downshift or drop into sport with shifter to get up over 2000 rpms before stabbing it.

Cruising at 1500 rpm at light steady throttle will not hurt the motor.

BD
 

·
Registered
2020 Ecoboost Premium 10R80 w/ Black Acct Pckg
Joined
·
91 Posts
Yes, mine will go all the way into 9th as low as 45 mph at light steady throttles, but if I want to accelerate, I slowly roll into the gas until it downshifts to 5th or 6th before I get past half throttle. If I need to accelerate quicker then either use paddles to downshift or drop into sport with shifter to get up over 2000 rpms before stabbing it.

Cruising at 1500 rpm at light steady throttle will not hurt the motor.

BD
Seconded, just be conscious of throttle inputs if you are lightly cruising around. The thing you want to avoid is demanding high power at a low RPM. So if you stab the throttle at 1500 RPM or less, you increase the likelihood of something bad happening (it might not happen the first few times, but why risk it).
 

·
Registered
Joined
·
1,051 Posts
^^^^THIS^^^^

BD
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #25 ·
I do the same thing, S mode in town!
Hey , question when in sport mode do is the shfiting alot harder? in my mustang it will pull the car back when slowing down and going into a lower gear.
also after the engine swap alot of things have started to fail lol, the car will sometimes not shift when into 2nd to 3rd - the rpms will skyrocket but the speed stays the same- my knock circuit is going off- i hear my turbo spool but it sounds almsot as if its spiiting the boost out not into the engine. i have about 1600 miles on the engines problems started at about 1500miles after going for some light racing. nothing higher then 5krpms was that what caused it?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #26 ·
I do the same thing, S mode in town!
Hey , question when in sport mode do is the shfiting alot harder? in my mustang it will pull the car back when slowing down and going into a lower gear
Sounds like you've gotten some very good advice! Something else you may want to check is for anything loose. On my last build, I didn't have any motor issues, but I did find a few external bolts that had backed off a touch and a loose hose clamp.
Also, remember to keep your RPMs up and never lug your motor.
Yeah i was thinking something had to be loose in the turbo or something ( what calmp was loose for you? )along with other things the car has now had some serious issues the car will sometimes not shift when into 2nd to 3rd - the rpms will skyrocket but the speed stays the same- my knock circuit is going off- i hear my turbo spool but it sounds almsot as if its spiting the boost out not into the engine. i have about 1600 miles
 

·
Registered
Joined
·
1,051 Posts
Is the check engine light on and if so any codes present. If boost hose clamp came loose or shifting issue are occurring there should be codes set with CEL illuminated.

BD
 
21 - 27 of 27 Posts
Top