Ford Mustang Ecoboost Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
Hey everyone,

I have been noticing over the last month every now and then my KOM readings are different. Running 93 tune from [email protected] PD tuning. Looks like possible poor gas? It seems to be at 1.00 but if I do a heavy pull it drops. So I have added three shots. Usually it will Show 0.000/1.000
 

Attachments

· Registered
Joined
·
213 Posts
I put Stabil 360 in over the cold months to keep any potential moisture at bay from the ethanol, I also use 1/2 a bottle per tank of Lucas Octane booster over the cold months. Why you'd say? Well 93 octane isn't always 93 octane, especially in the cold months. After hearing about way too many stories of delivery drivers dumping the rest of their 87 octane in the premium tank instead of taking it back from a fill I simply don't assume the premium I'm buying is completely premium. Especially in the cold months when less premium is sold due to a lot fewer performance cars being not on the road.
 

· Registered
Joined
·
56 Posts
Discussion Starter · #3 ·
Figured was an octane issue. I put Race Track 93 in the other day. I have used them from time to time and never really noticed anything. I have read using octane boosters are not a good idea. Fouls the plugs fast. I will fill up at my usual station next time and see how it goes.
 

· Registered
Joined
·
56 Posts
Discussion Starter · #4 · (Edited)
Got a hold of Ryan. Will need to send him a data log but he thinks it may just be a fuel octane issue from poor gas. I changed the fuel purge valve a few days ago because of issues after filling up and the fuel pressure regulator about 6 months ago. I think it may be a winter blend fuel issue. Filled up at the QT that we usually use and still had issues. The KOM readings drops after doing a hard pull when letting off the gas pedal and it’s just coasting. Also it seems that just about every time after the car sits it resets the the KOM values and I have to let it drive a bit before it reads it again. I don’t remember it doing this before.
 

Attachments

1 - 4 of 4 Posts
Top