Ford Mustang Ecoboost Forum banner
1 - 9 of 9 Posts

·
Registered
2017 Mustang Ecoboost
Joined
·
6 Posts
Discussion Starter · #1 ·
Greetings all, and for those with an idea of what to do, all suggestions are welcome.
My issues are thus. Randomly my Stereo/ climate control buttons will stop working as well as the thermometer on the Sync screen, which at the same time, it affects my rear turn signals, and makes them act as if they're is a blown bulb. But when it decides to operate properly, all turn signals, AC/ Stereo will work. Otherwise, I can't use my heat/ cooling systems, or change stations, eject CDs, control phone calls, outside of the controls on the steering wheel. My front signals/ hazards will work normally, but the rear will not. I wasn't having these issues until around a week after purchasing, and there are times it'll go DAYS without error, or it'll go DAYS with Error. Otherwise she runs absolutely fine, minus slight changes in what my mileage will read.
I have checked all of my fuses, checked the BCM, and done a Hard Reset, where it ran PERFECTLY, until I turned the car off...
What do I do? Again, Thank you for your time.
 

·
Registered
2017 PP MT DD
Joined
·
1,161 Posts
Check the loom in the rear trunk. The cables are 2 short and get stretched and need to be replace. You will have to open up the loom to check thoroughly and replace as required if your still not under warranty.

After that I would check the battery. Strange things happen when the battery is on it's way out. Half the lights stopped working on mine and then when you locked it they all stayied on for long time after they were supse to go out.
 

·
Registered
2017 Mustang Ecoboost
Joined
·
6 Posts
Discussion Starter · #3 ·
Mine is doing that too... internal lights either take forever to go off, or stay on... where exactly is the loom? I also checked my battery today, and my alternator is working 100%, but for some reason my battery is holding at 50%charge? That sounds very similar to what you're mentioning. So I'll look at that next. Thank you!
 

·
Registered
2017 PP MT DD
Joined
·
1,161 Posts
Here is the loom.

But it sounds like your battery is dead. If and when you change it don't for get to do a BMS reset
Tire Hood Automotive tire Motor vehicle Automotive lighting
 

·
Registered
2017 PP MT DD
Joined
·
1,161 Posts
Ok.i figured out the BMS.. Remove positive for ten minutes, etc, yeah?
Not quite. There are a specific sequence of light flashes required while in ACC or a AP is required.. If you do a search your find the specifics
 

·
Registered
2017 PP MT DD
Joined
·
1,161 Posts
1 - 9 of 9 Posts
Top