Ford Mustang Ecoboost Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Have about 6500 on my 18, when I'm going up hill the engine feels like it's surging, I can feel it when I'm accelerating normally. Not as bad when I get on it.
Any Ideas.
JTL COI, JTL Drivers side catch can are the only mods.
 

·
Registered
Joined
·
1,302 Posts
Have about 6500 on my 18, when I'm going up hill the engine feels like it's surging, I can feel it when I'm accelerating normally. Not as bad when I get on it.
Any Ideas.
JTL COI, JTL Drivers side catch can are the only mods.
Any tune on it? If so, remove the tune temporarily and test it uphill again. I've been experiencing the same thing and after troubleshooting and checking out my spark plugs, air filter, air box, lines and a few sensors, only to find the surging was still there, I finally de-tuned the car temporarily, where the surging went away.
 

·
Registered
Joined
·
6 Posts
Not to restart an old thread. But i am...
I just purchased my 2019 performance pack EcoBoost with magneride paired with the mt82 tranny (notchy as hell gears with occasional. double clutching eliminates but sucks every upshift) a couple weeks ago. Have 1500 miles on it. Love the car. But last week i noticed something similar happening. When under a load in 1-3 gear such as starting out on a big a hill or 80% acceleration in 1-3 i get very quick power surging almost like the power is going between normal driving mode and sport mode (that power increase decrease felt when swapping modes) it doesn't do it all the time. Fuel ratio is always around 14 when it happens and i see boost staying steady. I try to replicate it by slowly increasing rpms holding a gear but doesn't happen. Only on acceleration. i really don't recall feeling this the first couple weeks with the car and it seems to be getting more regular. No tune no mods (yet :devilish:)
 

·
Registered
Joined
·
1,591 Posts
Did you buy the car new?.

A virgin tune with 87 octane fuel in the tank will make the car feel very subdued.

Add some break-in miles and some better fuel and now you can really feel the boost surge when accelerating.

Boost comes in response to load, heavy load means the car will make more boost and give a noticeable shove felt in the seat of the pants, light to no load and very little boost is made.

As far as the mt82 goes there are dozens if not hundreds of videos on YouTube with ways to make the mt82 more user friendly.
Here is a few that cover some simple modifications that many find improve the drivability of the mt82.










Sent from my SM-G981W using Tapatalk
 

·
Registered
Joined
·
6 Posts
Thanks for your reply. Yea only 36 miles on it. I put about 1450 since i bought it new. Have only ever run 93 octane. Its weird as it seems to have gotten worse but didn't do or i didnt notice it when first bought. I say about 2.5 tanks ago. Its a very fast rapid surge in power under load/acceleration not smooth or better yet drop in power and pulsing up and down. I almost never notice it WOT. Mainly 50-80% And it only happens higher in the rpms say around 4k and above after turbo is spooled. Maybe it needs a longer break in and calibrate? We have been having warmer slightly humid days could moisture be building/condensing during cruising in the IC and being pushed out when i go aggressive? To think about it. Its warm and rainy today and today was the worst i noticed it happening prompting me to reach out here. have heard that is an issue at times. I plan on the BG fluid swap. I have looked at shifters i noticed a mgw and the steeda i like the Barton but the web site claims gt only. Seems it would fit the ecoboost as they are the same trans right? Appreciate those vids didn't think about doing the spring. I'll definitely give it higher priority.
 

·
Registered
Joined
·
1,591 Posts
Slight stutters in part throttle power above 4000rpm could be a few things.

Spark plug blowout from oversized plug gaps. The car is new so this is not likely.

Timing retard, during part throttle acceleration the ecu is advancing timing to the knock limit then backing off then repeating the process again. This process can be felt as slight variations in power.
A better explaination of this process is found in this article-


Mechanical issue, something with the variable valve timing, blow off solenoid or waste gate, you usually get an engine light for any if these conditions.

Sent from my SM-G981W using Tapatalk
 

·
Registered
Joined
·
6 Posts
Thanks. Yea i assumed i would get a light also. I may just check the plugs just in case. Anything wonky with tightening or loosening the plugs in these e 2.3l eco engines? I have a 5.4 that spit 3 out before i rebuilt the engine and put new ones in myself.
 

·
Registered
Joined
·
1,591 Posts
The 2.3 has much better thread engagement than the 5.4 so you shouldn't have any issues with plugs popping out but there has been the odd complaint from owners finding their factory plug gaps were all over the place, i assumed that issue was corrected after the s550 production had matured but it don't hurt to look.

Sent from my SM-G981W using Tapatalk
 

·
Registered
Joined
·
6 Posts
Thanks. Btw i noticed you are in a thread discussing a mishimoto clone/rebranding IC awhile back. Did it hold up over time? Seems promising and I'm tempted to buy it. Clone/rebranding doesn't bother me one bit had great success in the past with them.
 

·
Registered
Joined
·
1,591 Posts
The clone never gave me any issues and to my knowledge still resides in the car to this day (I sold the car so it is no longer in my possession).

Sent from my SM-G981W using Tapatalk
 

·
Registered
Joined
·
1,803 Posts
The clone never gave me any issues and to my knowledge still resides in the car to this day (I sold the car so it is no longer in my possession).

Sent from my SM-G981W using Tapatalk
Hahaha. Do you see it around? That would be weird for me. 😅
 

·
Registered
Joined
·
6 Posts
So its still doing it went through another tank of 93. Will pull plugs in a bit if rain holds off. Also i noticed my Inlet air is now spiking high. It used to stay around 2-5 degrees above ambient but now getting 30+ i know its not charge temps but higher inlet would also creep up charge temps right?
 
1 - 15 of 15 Posts
Top