Ford Mustang Ecoboost Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
120 Posts
I have the same one as you for the rear. Actually tried installing them (poorly) but they didnt work out so i removed them and am going with my own 3M vhb tape and more adhesion promoter this time around. Have been anxiously waiting for a warm few weeks since September lol
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #5 ·
I have the same one as you for the rear. Actually tried installing them (poorly) but they didnt work out so i removed them and am going with my own 3M vhb tape and more adhesion promoter this time around. Have been anxiously waiting for a warm few weeks since September lol
Should look good the matte/gloss black should match really well. I feel the itch though I'm waiting for it to warm up to do more exterior mods to it. The 3M tape wasnt awful but once it warms up im removing it to get something slightly stronger and i miss aligned one of the pads to keep it off the glass so im fixing that aswell.
 

·
Registered
Joined
·
10 Posts
I have a similar rear Louvers on my 2016. Does anyone else have rattle issues? Mine seem to rattle at any speed over about 30mph. Did I just get a cheap set, or is everyone having the same issue?

Alan
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #7 ·
I have a similar rear Louvers on my 2016. Does anyone else have rattle issues? Mine seem to rattle at any speed over about 30mph. Did I just get a cheap set, or is everyone having the same issue?

Alan
I had a slight rattle when I first put the rear louver on as the top of each corner would hit the window while over ~40mph. If you have extra 3m tape I’d say see if you can find where it’s rattling and try putting the double sided tape in strips around that area and hold it down for a couple minutes to set it. Seemed to work for my set atleast.
 
1 - 9 of 9 Posts
Top