Ford Mustang Ecoboost Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone. I was hoping I could get some advice on some issues I am having. I recently purchased a 2019 Mustang Ecoboost with 30k miles on it. The first couple of months I had it things were going pretty well. I haven't done any mods yet as I was waiting for some nicer weather. Oddly, my MPG has decreased pretty dramatically the past 6 weeks. Nothing has changed in my driving habits, tire pressure is good, filters are clean but I am getting a combined 20 MPG. Most of my mileage is highway and I was getting closer to 30 MPG until the last month and a half. On top of that, my car has started to get a bit jumpy out of first and when downshifting. Nothing major, just different than it was when my MPG was normal. Took it to a mechanic yesterday who couldn't find anything wrong with it. Anyone have a similar experience? Any advice? Thank you so much for your time.
 

·
Registered
Joined
·
1,022 Posts
I'm presuming you're driving an A10. There have been several threads complaining about crappy shifting, particularly harsh downshifts in D when coming to a stop, 4-3 seems to be the most affected. My car is starting exhibit this (at approximately 38K kms/24K miles) although not as severely as others, but it seems to be less when the transmission is up to temperature, and is something I will be keeping an eye on since I will be out of factory warranty in July 2023. The fix typically is replacing one of the valve bodies in the transmission. I would be taking it into the dealer if it is severe.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you for your reply. The shifting definitely isn't too bad yet, but the MPG really makes me think something is wrong. I wanted to avoid tearing the transmission down but it's not giving me any codes and I'm not sure what else to do. I could replace the sparkplugs for the heck of it but they should be fine and there are no misfires. Has anyone had luck replacing the spark plugs early with new OEMs and found an improvement?
 
1 - 3 of 3 Posts
Top