Ford Mustang Ecoboost Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I tried my best and accelerate like a Prius, but I still can’t get higher than 12.5mpg in last 50 miles local. Also, I can only get 20 mpg on freeway... Is there problem in my car? I brought last month. I had 900 miles on it right now.
 

·
Registered
Joined
·
157 Posts
I suggest you take it to the dealer. Anything else said with so little information is guessing.

That said a friend had a similar problem, and it was a faulty low preassure fuel valve.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I suggest you take it to the dealer. Anything else said with so little information is guessing.

That said a friend had a similar problem, and it was a faulty low preassure fuel valve.
Thank you! Hopefully they can find out what’s going wrong
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
After a bunch of research,I found the low pressure fuel sensor # is BU5A-9F972-BA
Is it related to my issue?
 

·
Super Moderator
Joined
·
3,237 Posts
Given the limited information and low mileage on the car it's hard for us to troubleshoot this issue over a forum. I would certainly take that information to the dealer and ask them wile they troubleshoot the issue.
 

·
Super Moderator
Joined
·
6,149 Posts
Simple question ... what octane fuel are you running?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
My car is Mustang EcoBoost 2019 premier with black accents package. I didn’t find any other issue on driving the car.(maybe there is but I didn’t notice.) I use 91 octane fuel from shell or Costco. A month ago, I get average 15 mpg on local when I just get the car. And I did deep steps at that time. Now I drive like a Prius and can not get higher than 12.1 mpg. And there is 900 miles on my car right now
 

·
Registered
Joined
·
1,625 Posts
My car is Mustang EcoBoost 2019 premier with black accents package. I didn’t find any other issue on driving the car.(maybe there is but I didn’t notice.) I use 91 octane fuel from shell or Costco. A month ago, I get average 15 mpg on local when I just get the car. And I did deep steps at that time. Now I drive like a Prius and can not get higher than 12.1 mpg. And there is 900 miles on my car right now
Your engine is just finishing the breakin process so mileage will be a little worse than normal until everything is nicely worn in but 12mpg is pretty bad.

To really be sure get on the open road, no stop signs or traffic lights, just wide open flat highway, get the car up to 60 miles an hour and reset your fuel economy monitor.
Drive at a steady speed for at least 10 minutes, if you cant get better than 28mpg then you have a serious issue that needs to be reported to the dealership immediately.

Sent from my SM-G960W using Tapatalk
 
1 - 8 of 8 Posts
Top