Ford Mustang Ecoboost Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hello everyone.
I own ecoboost 2017 and today had a problem.
After driving home my car didn’t start.
No error codes (dtc is clear).
Battery is ok (car is opening, music ands lights working)
After push the start button- it starts clicking and then shutting down. After few seconds starts the ON mode, but not the engine.
What it could be?
 

·
Registered
Joined
·
2,122 Posts
Will it remote start? If it does just can be a bad connection with your push button especially if you modified it or changed it at all.. if not sounds like it could be an issue with your starter.... even though your battery seems to be okay I would still double check all the connections and make sure nothing's loose
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Will it remote start? If it does just can be a bad connection with your push button especially if you modified it or changed it at all.. if not sounds like it could be an issue with your starter.... even though your battery seems to be okay I would still double check all the connections and make sure nothing's loose
remote start the same problem... blinks the light and clicks...
"double check all the connections" which connections?
 

·
Registered
Joined
·
2,122 Posts
The ones going to your battery check all your fuses and also follow the wires to your starter make sure nothing got damaged or bent or anything on the bottom of your starter solenoid
 

·
Registered
Joined
·
861 Posts
That sounds no different than a weak battery without enough current to turn the car over. I would say a battery is your issue.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
That sounds no different than a weak battery without enough current to turn the car over. I would say a battery is your issue.
I was trying to start from another car and try to charge from another car and then start - nothing:(
 

·
Registered
Joined
·
2,294 Posts
The exact same thing happened with my wife's Dodge. Lights, accessories worked but car just clicked when you pushed the start button and I couldn't jump it. Put my battery charger on it for a couple of hours and no luck either.

I was just going to buy a new battery but when I found out the cheapest battery was $175. Car was still under warranty so just called the dealer and had them come a get it. New battery and all is well.

The absorbed glass mat batteries they use these days have a reputation of not giving any warning before giving up the ghost.

Dave
 

·
Registered
Joined
·
861 Posts
I was trying to start from another car and try to charge from another car and then start - nothing:(
Sometimes a dead cell will not let you jump start it and it will read a full 12 volts. If you used a battery load tester, it may show this. This is another reason I love a manual transmission. I hope you get her fixed!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
So, the problem is bigger than I thought... The 4th cylinder is completely destroyed :eek:
We don't know exactly what happened... Maybe later when the new engine will arrive, we will make big diagnostic with the damaged engine...
 

Attachments

·
Premium Member
Joined
·
2,558 Posts
Mine is doing the same thing and my engine is very low on oil and it looks like the engine is locked up
Do you have an obvious oil leak?
 

·
Registered
Joined
·
2 Posts
So my boyfriend has the same problem and he hears clicking under the hood. The car won’t start by jumping until after the clicking stops. His battery is good and only one of the terminals/connections was corroded and they cleaned it. He closed the door and the car locked by itself and he couldn’t get it open by the key fob and barely open it with the stored key. Does anyone know what the issue could be?
 

·
Registered
2017 PP MT DD
Joined
·
936 Posts
So my boyfriend has the same problem and he hears clicking under the hood. The car won’t start by jumping until after the clicking stops. His battery is good and only one of the terminals/connections was corroded and they cleaned it. He closed the door and the car locked by itself and he couldn’t get it open by the key fob and barely open it with the stored key. Does anyone know what the issue could be?
I would say the battery's had it by what you have described.
 
1 - 20 of 22 Posts
Top