Ford Mustang Ecoboost Forum banner

Has this hesitation happened to any of you ?

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I bought a 2020 ecoboost mustang brand new it was running GOOD AND STRONG until like 10k miles , I slowly started to notice hard shifting and never felt like the car responded to the throttle accurately, Now at 30K Miles The car feels slower , i tired to do 0-60 times and I would usually get 6.1-5.7 time but now I’m in the 7.5-6.9 times , I noticed also when trying to accelerate onto the free way and I floor it to give it gas it revs out and but it doesnt feels like it’s putting any power down… throttle response just doesn’t feel right And the whole car just being unresponsive and it just feels over all extremely slow acceleration , could I be overthinking it and it could possibly be because it’s a turbo car or could their be something wrong ? ( 2020 ecoboost base model 10 speed transmission) completely stock !
 

·
Premium Member
Joined
·
1,759 Posts
I bought a 2020 ecoboost mustang brand new it was running GOOD AND STRONG until like 10k miles , I slowly started to notice hard shifting and never felt like the car responded to the throttle accurately, Now at 30K Miles The car feels slower , i tired to do 0-60 times and I would usually get 6.1-5.7 time but now I’m in the 7.5-6.9 times , I noticed also when trying to accelerate onto the free way and I floor it to give it gas it revs out and but it doesnt feels like it’s putting any power down… throttle response just doesn’t feel right And the whole car just being unresponsive and it just feels over all extremely slow acceleration , could I be overthinking it and it could possibly be because it’s a turbo car or could their be something wrong ? ( 2020 ecoboost base model 10 speed transmission) completely stock !
That's a bit on the slow side. Have you gotten any fault codes? How's your gas mileage been? Also, what are your temperatures and boost levels??
 

·
Registered
Joined
·
67 Posts
Try retightening all the clamps on the turbo and piping.
 
  • Like
Reactions: Coyote Chaser

·
Registered
Joined
·
362 Posts
Also make sure something like a plastic bag didn’t get ingested from the road into the airbox to restrict flow. Funny story behind that!
Thanks for the good laugh......I somehow ingested a bunch of bees! Normal maintenance is how I found them. Sort of freaked me out to have apparently run through a swarm of bees and didn't know it. Really strange, wild, stuff...😅
 

·
Registered
2016 ecoboost premium
Joined
·
121 Posts
if your under warranty take it to ford. your 10 speed ecoboost shouldnt be slower than my 6 speed ecoboost
 
  • Like
Reactions: Ese_ulii

·
Premium Member
Joined
·
1,759 Posts
Thanks for the good laugh......I somehow ingested a bunch of bees! Normal maintenance is how I found them. Sort of freaked me out to have apparently run through a swarm of bees and didn't know it. Really strange, wild, stuff...😅
Wheel Car Tire Vehicle Hood

I don't do much street driving, but I did trailer my car 6,000 miles last year, which is why I installed a mask over the front openings... mostly for rocks! But, I guess it will slow down a swarm of bees!? LOL
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #9 ·
That's a bit on the slow side. Have you gotten any fault codes? How's your gas mileage been? Also, what are your temperatures and boost levels??
i haven’t gotten any codes ,my Gas mileage has kinda been shiii as well around 13-15 mpg city with absolutely conservative driving , cylinder temp usually 180-200 , intel air temps around 80-100 , I have noticed my boost levels low pushing 14-15 psi when I would do 20-22 … I was thinking maybe because I’ve been trying to baby my car to see what’s the best MPG I could get , But today I tried to floor my car and it just doesn’t feel right , like a lost of power the low RPM torque just isn’t their at first I was thinking maybe I’m getting use to the acceleration but I rarely even drive spirted the , maybe I should stop procrastinating thinking it’s not a problem and just take it to the dealers I’m just worried they will say nothings wrong since theirs no codes
 

·
Premium Member
Joined
·
1,759 Posts
i haven’t gotten any codes ,my Gas mileage has kinda been shiii as well around 13-15 mpg city with absolutely conservative driving , cylinder temp usually 180-200 , intel air temps around 80-100 , I have noticed my boost levels low pushing 14-15 psi when I would do 20-22 … I was thinking maybe because I’ve been trying to baby my car to see what’s the best MPG I could get , But today I tried to floor my car and it just doesn’t feel right , like a lost of power the low RPM torque just isn’t their at first I was thinking maybe I’m getting use to the acceleration but I rarely even drive spirted the , maybe I should stop procrastinating thinking it’s not a problem and just take it to the dealers I’m just worried they will say nothings wrong since theirs no codes
What type of device are you using to check for codes?
 
1 - 10 of 10 Posts
Top