Ford Mustang Ecoboost Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
390 Posts
Discussion Starter #1
I was driving my 2015 EcoBoost for the first time in months, since I have been laid up from surgery. I went to pass someone and I felt a hesitation. The check engine light came on. I hooked a code reader up to it and got P0234. All I know is it has to so with the turbo. Any help would be appreciated! Thanks!


Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
887 Posts
I was driving my 2015 EcoBoost for the first time in months, since I have been laid up from surgery. I went to pass someone and I felt a hesitation. The check engine light came on. I hooked a code reader up to it and got P0234. All I know is it has to so with the turbo. Any help would be appreciated! Thanks!


Sent from my SM-G975U using Tapatalk
Might be a faulty or blown wastegate. That can cause overboost on the turbo. The engine retards timing anytime it sees too much boost.
 

·
Registered
Joined
·
80 Posts
clear it and forget about it unless it keeps showing up. it means the ECU saw boost pressure higher than what it expected. it happened to me too and no boost at all until i cleared it. i have the ford performance race pack ECU though so it may be different.
 

·
Registered
Joined
·
390 Posts
Discussion Starter #4
clear it and forget about it unless it keeps showing up. it means the ECU saw boost pressure higher than what it expected. it happened to me too and no boost at all until i cleared it. i have the ford performance race pack ECU though so it may be different.
I don't have anything but the plugs that burn colder, K&N filter, and Airraid intake tube.

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
390 Posts
Discussion Starter #5
I cleared out the codes that last day I posted and it has yet to come back. It does act sluggish on boost intermittently.

Sent from my SM-G975U using Tapatalk
 
1 - 5 of 5 Posts
Top