Ford Mustang Ecoboost Forum banner
41 - 60 of 67 Posts

· Registered
Joined
·
857 Posts
I have always done the uninstall of my COBB tuner prior to bringing in for dealer service. My service manager knows I run a tune, but I had a bad experience with my 2015 where they did a PCM flash (tune not removed) which caused all kinds of grief to get straightened out.
 

· Administrator
Joined
·
3,950 Posts
I've always left my tune on when I took it to the dealer. They never had any trouble plugging in and reading things and telling me that it was obviously tuned...
 
  • Like
Reactions: DRU842

· Registered
Joined
·
123 Posts
It's never been an issue for my dealer either.
 

· Registered
Joined
·
37 Posts
Discussion Starter · #46 ·
Just received update from service advisor:
Head tappets were installed yesterday, but noise was still present on startup this morning. They're contacting Ford to see if they need to replace the head again or new motor. Awaiting their decision. I requested new motor.
 

· Administrator
Joined
·
3,950 Posts
changing the block won't change the engine computer.
 
  • Like
Reactions: chrisrandolph59

· Administrator
Joined
·
3,950 Posts
If they're getting it from Ford, it'll most likely be the updated block.
 
  • Like
Reactions: chrisrandolph59

· Registered
Joined
·
45 Posts
They said they couldnt get their computer to connect so i went down and uninstalled cobb accesport. Day and a half later havent heard back.
So nobody had trouble getting warranty with a tune on car?
Did anyone else have the upgraded turbosmart installed?
If not covered assuming its going to need a new motor also and still owing $14k on the car i dont think it would be worth paying for repair. Can buy same car 3 years newer fewer miles for $24K
 

· Registered
Joined
·
37 Posts
Discussion Starter · #52 ·
I just have the tune and a k&n drop in. I've never had an issue with them honoring a warranty. I've bought 4 cars, 3 mustangs and a fusion from this dealership, all were tuned or modified and they've never denied a warranty. I was always honest with them and explained that I was familiar enough with motors to know that my bolt ons or tune did or didn't cause said issue.
Good luck
 

· Administrator
Joined
·
3,950 Posts
So nobody had trouble getting warranty with a tune on car?
Oh I never said that. I said I didn't remove the tune and they never had trouble pulling codes or reading the computer because of that.

I've had to pay for the head gasket, twice now. The only warranty work I've got out of the dealer was when my back up camera failed... And I still need to go back for the recall on that.
 

· Registered
Joined
·
857 Posts
So nobody had trouble getting warranty with a tune on car?
This is a very subjective area. Much is determined by your relationship with the dealer and by the quality of their service crew. If you read through other's dealer experiences on this forum you will see the whole gamut, excellence and will diligently work with you at one extreme to total incompetence and lack of regard for you as a customer or your ride at the other extreme. I have dealt with both extremes, though the norm is somewhere to the good side of the middle of those extremes. I am lucky in that I have 2 dealers very close to me and another 3 not that far away, so I have choices.
 
  • Like
Reactions: DRU842

· Registered
Joined
·
45 Posts
I was able to connect accessport and uninstall it no problem, I told him the codes i was getting and he doesnt care they need connect computer. They are turning mechanical issue into electrical.
Its got a head gasket leak and cam sensor issues.
 

· Registered
Joined
·
1 Posts
They called said they can not communicate with the car to come get it take somewhere else. Pay them for 1hr. Im going to take it straight to autozone see if they can, my accessport can read it.
I had a similar issue. My car was misfiring, but their computer was not reading anything wrong. I was told it was “$200 for connecting their computer”. Also, to do an engine tear down would cost me $198 per hour…
 

· Registered
Joined
·
45 Posts
They told me they cant get their computer to connect to my obd port. Right after i connected my accessport and removed it. They 1st said it was the tune on car keeping them from being able to connect.
I paid $100 to have the car towed to them and $89 to do nothing. Tomorrow i will uber over there pick it up guess drive it home.
 
41 - 60 of 67 Posts
Top