Ford Mustang Ecoboost Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
First this monday morning I went outside to start the car and head to work . Cranking time seemed to be longer than usual and more labored . Started heading down my street and the issues began . Pulling out on to a road while shifting into 2nd the car bogged down for a few seconds , then came back and continued on . Made it about 4 blocks down the road and pulled out onto the highway . Same thing happened again , 2nd gear shift and more bogging . This time the car died and left me rolling down the highway with a stack of cars behind me . I was able to restart the car , and make it the 2 blocks down the road to the closest gas station. I was pretty low on gas with approx 30 miles remaining in the tank . I filled my tank and drove the 1.5 miles down the highway to my workplace with no issues . Fast forward to closing time and the car wont start . It will crank and crank but not fire off . I keep a code reader in the car so I pulled up codes : P0627 and P00C6 .

2016 Mustang Ecoboost Premium 6MT , 51,000 Miles.

Searching around on the web it seems as ford has some issues with Fuel Pump Control Modules. I ordered a new one, and just in case ordered a new fuel pump as well ( Only 166$ for motorcraft on RockAuto).

Got the module changed out last night , no luck . Still cranks but wont start . Swapped in the new Fuel pump and it fired right up. Cleared the codes and drove around for awhile . All seems to be well at this point . Hopefully this may help someone else if they have a similar issue with these codes!
 

·
Registered
Joined
·
2,606 Posts
This just happened to my friend's F150. His symptom was that the car would crank, and crank, and crank, but no turnover. Spark was there, but obviously no fuel. It had to be either the pump or the module, and it turned out to be the module.

Thanks for posting this. Feel free to stick around and peruse!
 
1 - 2 of 2 Posts
Top