Ford Mustang Ecoboost Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2017 Ecoboost mustang with 47k miles
No warranty

Car continues misfiring horribly.
I am getting oil on the electrode of the 3rd cylinder spark plug. when I change the plug it runs fine for a couple of minutes and then it starts to misfire again.

I got the valve cover and gasket replaced. I also replaced the PCV valve. After trying to deal with the situation my self I finally went to a shop and they are doing a compression test.
I believe it is the valve stem seals because oil is pooling inside spark plug well and only gets onto the threads of spark plug.

Any thoughts on the situation would be very much appreciated
 

·
Registered
Joined
·
29 Posts
If you have oil pooling in the cylinder so quickly its most likely valve seals.

Actually just re read that, are you saying there is oil on the spark plug threads and its not getting into the cylinder?
 

·
Registered
Joined
·
29 Posts
No you had it right but Sorry I meant it’s not on the top part of the plug.
Then its most likely valve seals, other long shot could be that you have a oil seal bad internally on the compressor side of the turbo and oil is getting sucked into the engine, but youd probably have misfires on all 4 cylinders if that were the case.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Then its most likely valve seals, other long shot could be that you have a oil seal bad internally on the compressor side of the turbo and oil is getting sucked into the engine, but youd probably have misfires on all 4 cylinders if that were the case.
Thank you so much
 
1 - 6 of 6 Posts
Top