Ford Mustang Ecoboost Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter · #1 · (Edited)
View attachment 23211
E0249327-3E99-413C-8300-18B647F06A8C.jpeg


So I attempted this install at work today,


6C0F4155-F1EE-44A2-BE1A-81A0A7E8FAE9.jpeg


Everything looked good when I opened the box and got the baffled screwed in.
Then I went to tackle manifold.

Intake came off rather easily once everything was disconnected. Then I ran into another issue. The kit came with with the wrong plug. I’ll be contacting radium on Monday and requesting the proper 10an plug for the kit. Everything else looked good, but kinda sucks I took everything apart for no reason. Lesson learned for everyone. Check to make sure you have everything before you start tearing into anything. Btw for those wondering why you need a catch can. The intake tract in the manifold has a little oil in there.
 

·
Registered
Joined
·
1,131 Posts
Thanks for the tip. I ordered one of those from Ebay when they did their last Father's Day sale. I'll check the plug when I get it.
 

·
Registered
Joined
·
309 Posts
Discussion Starter · #3 ·
Update from company, they just needed proof of purchase and are sending the correct piece directly.
 

·
Registered
Joined
·
309 Posts
Discussion Starter · #5 ·
So I ordered these quick connects, and installed the 1/2” check valve from upr. The quick connects are not going to work for me. But I ordered a 1/2” barb 10AN that will. Below is the different sizes of fitting I had. Middle is what comes in the radium stock kit. I’ll have to wait til the new fitting comes to install the plate... but it should flow much better and will not flow backwards with the check valve.
650378E8-16CC-4712-842F-83C31CCAE084.jpeg
C5E54483-E45F-4D25-BD04-A317ABAA5216.jpeg
 

·
Registered
Joined
·
52 Posts
I just installed the radium plate, with 1/2 hose barb going to my UPR DVCC. At first I had the 50psi check valve, before the manifold, and was getting so much blow by into my intake manifold. So I ordered a 100 psi billet check valve and still same thing. I went for 100k kms drive and must of had 100 ML maybe more of oil dripping out of the manifold. When I pulled the charge pipe off, it was puddledup on the throttle body inlet. I have no idea how to fix this LOL. Anyone else have any similar situations? I have a clean side catch can coming now to. Should I have the 3/8 check valve at the baffle plate from radium as well? I just want to start tuning my car, but obviously I need to fix this issue first. I think I been having a blow by issue for some time, because when I did my head gasket in the spring, there was a lot of carbon build up on the intake valves for 50k kms on car. Fortunately when I had my cylinder head vacuum checked, most of it came off. I do remember seeing some blow by in the manifold when I was pulling the head off, just not as much as I’m seeing with the radium plate. I appreciate any help, and figured I would just bump this thread, instead of making a new one 👍
 
1 - 6 of 6 Posts
Top