Ford Mustang Ecoboost Forum banner
21 - 30 of 30 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #21 ·
Updated post 2021: My car gave me a few codes, and I never fixed anything. P0456 & P144C. I replaced the Evap Purge Solenoid Part Number - FR3Z-9G297-H and it stopped the shaking. My codes were cleared, and never returns.
 

·
Registered
Joined
·
202 Posts
Sounds like classic ford evap purge solenoid failure.

There is a system in place to draw fuel vapor from the gas tank and feed it into the engine to keep gas fumes from getting into the atmosphere and contributing to smog, if it fails it can allow raw fuel to be pulled through the vapor lines or create a vacuum leak which messes up the air fuel ratio and makes the car run poorly.

Evap Purge Solenoid Part Number - FR3Z-9G297-H

The part is pretty cheap and simple to replace.


Sent from my SM-G960W using Tapatalk
Hey there i've replaced mine but every now and then i get the same shake is this purge solenoid something i should stock up on and its on its way out again ? ....tks vince
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #23 ·
Hey Vince, quick Q. When you fill up your tank, does it ever give you trouble? Like does it click multiple times, and never let the pump give you a full tank? I hope that makes sense lol.
 

·
Registered
Joined
·
202 Posts
Hey Vince, quick Q. When you fill up your tank, does it ever give you trouble? Like does it click multiple times, and never let the pump give you a full tank? I hope that makes sense lol.
it did when it was new but it fixed itself what i did was just go slow till it was completely full without clicking off now it fills fast all the time ,just still have the shaking every now and then ...vp
 

·
Registered
Joined
·
1 Posts
Hey what’s up quick question was the BOV you were running the hks and if so were you able to solve the problem ? I’m having the same issue right now but I’m not sure exactly what it might be .




I’m quite new to this forum I am having the same issue with my car rough idle and low air fuel mixture after I fill up and believe this is the culprit of it the problem is I’m running a blow off valve which requires I cut the hard plastic line that connects from this part to the throttle body and replace it with the rubber line from the blow off valve might this also be affecting the car in some way I have all the factory parts that I removed when doing this for a scenario like this would the BOV have anything to do with this or would it probably go away if I just replaced the part and went on to also install the blow off valve
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #28 ·
Hey what’s up quick question was the BOV you were running the hks and if so were you able to solve the problem ? I’m having the same issue right now but I’m not sure exactly what it might be .
I had a boomba racing BOV. I solved the problem but it came back later. One of my tubes was loose, was fine months before I sold it. It didn’t have to do with my blow off valve though! Hope that helps.
 

·
Registered
Joined
·
901 Posts
I do 1 click off when filling up and replaced the purge valve with the updated one and all is good 👍. vp
This is what you are supposed to do but I think there are a lot of people who still try and top it right off, which was okay when tanks were vented to atmosphere and all we had was a pcv valve on a valve cover with a line to the air cleaner (and carb!) but will screw up a modern fuel system right quick.
 

·
Registered
Joined
·
163 Posts
Mine does that. I suspect it's 'cause I fill it too full. Hard habit to break, but it's the only way to properly keep mileage stats.
You don't have to top off to get good stats. Different pumps flow at different rates and click off at different times, but it all averages out over time. According to the Owner's Manual, three tankfuls will yield an accurate average.
 
21 - 30 of 30 Posts
Top