Ford Mustang Ecoboost Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hey everyone, I recently got the email to update my SYNC 3 to version 3.0 and be able to use Apple CarPlay. I already ordered the USB adapter needed for this but cannot for the life of me get the update to work!! I have a 2016 non-nav currently with SYNC 3 1.0. I followed all directions online to a T and the update tried to install, would go for 5 minutes say it was complete then after restarting would say that it was a “Bad Installation File”. I spoke with support and they told me to do a master reset then try again, did that didn’t work. Now after the master reset I plug the USB in and it immediately tells me it’s a bad installation file and doesn’t even try to install. I have the USB piece coming in tomorrow for Apple CarPlay but can’t update the system!! So STUPID!! I spoke with dealership and they said that I have to update from 1 to 2.2/2.3 then to 3.0 and that should work, also that they can update for me but it will run me $120 which is absolutely ridiculous. Any help would be greatly appreciated !!
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Do you originally have the premium? I was mistakenly entering my non-premium VIN into the Ford website and mistakenly downloading the wrong file. See here:

Updating your Sync3 version
Yes, I have a premium and have been entering the right VIN in for the download. I read through your thread before and wasn’t able to help me unfortunately.
 

·
Registered
Joined
·
1,903 Posts
Did you reformat the USB memory stick to EXFat before copying the files to the stick?

Dave
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Did you reformat the USB memory stick to EXFat before copying the files to the stick?

Dave
Yes, I did everything correctly and tried a ton of different troubleshooting techniques. Took to dealership to just have them do it on Friday, Fords servers were down so they couldn’t download the update to install on my stang. Taking back Monday morning to have them attempt again. They said nothing was wrong with my sync, but that the Ford website is BS in telling us that you can go from SYNC3 v1.0 straight to 3.0, they say that they have to go from 1 to 2.2 to 2.3 then to 3, possibly even more updates in between there. Idk what the issue is but the updates Ford have me for my update we’re BS, possibly corrupted files cuz I couldn’t do anything with them. Hopefully dealership gets it done tmm and I can enjoy Apple CarPlay
 

·
Registered
Joined
·
1,903 Posts
Not sure about going from 1.0 to 3 but my car came with 2.2 and i went straight to 3.0.

Dave
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7
UPDATE: dropped car off at dealership this morning, they came back saying my APIM module is not working properly. Repair is $1,100, Ford will help with $270 bringing my total around $820 for a new APIM just so I can update the software lol. My sync system has had ZERO issues whatsoever and the only time it’s had an issue was when trying to install the update, but dealership says the module is no good and needs replaced. Looks like I am just going to stick to my regular v1.0 system and not have Apple CarPlay, or maybe buy a used module from someone online and see if that works. I will be calling Ford myself soon to try and speak with someone about this and maybe get a bigger discount. POS sync!
 

·
Registered
Joined
·
1,903 Posts
There is a listing on eBay for new APIM modules, non nav, with Sync 3 ver 3.3 or 3.4 for $159. There are 9 available.


Dave
 

·
Registered
Joined
·
30 Posts
Discussion Starter #9
UPDATE/SOLVED: OK, So!! Just got the car back from the dealership last night, and I wanted to try one more thing. I went and bought a $5 16GB USB 2.0 just to see if this would work, I put the update on the stick and tried to install, this time the update actually tried to install and then gave me an error that Installation Failed, install could not be installed properly due to lack of space or doesn't work with this version or something like that. I WAS ECSTATIC! Finally an error code that I could find some answers on. I did some research and there was a guy who went through same issue as me, is an IT Engineer and manipulated the autoinstall.lst coding to make the update install in 3 separate parts, 1.) the update 2.) the grace note and 3.) the file generation to send back to Ford. I will attach the link below. I followed this guys instructions and installed the update with my brand new USB drive and VOILA!! IT WORKED!! I cannot believe that talking to 4 different people at Ford support did not get me to a solution like that nor did taking the car to the dealership. The dealership basically saw no money in helping me find solutions to this problem and did not want to put the time in, so they lazily just suggested a brand new APIM module to see if that would work, even though it would run me $1,100. I can understand them suggesting a new module IF AND ONLY IF, the SYNC system was acting up and unusable, but the module was perfectly fine, has never had any issues up until trying to update the system. Moral of the story, Ford support has the troubleshooting skills of a toddler, Ford dealership only wants your money for huge repairs and doesn't want to put the time into something for free and that us owners need to continue to be independent from these guys and figure this stuff out on our own!! Google is a magical tool. BTW, apple CarPlay is awesome and totally worth the USB $50 hub upgrade plus software upgrade. If anyone runs into issues installing the update, try this tactic it may save you tons of time and headache.

 
1 - 9 of 9 Posts
Top