Ford Mustang Ecoboost Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I have a '19 performance pack and I've been running Cobb stage 1 for a few thousand miles. When I got my CVF intercooler (cobb said it'd be ok) installed, I drove home on stage 1. I tuned it to stage 2 and when I started it up, it idled rough and died. I tuned back to 1 last night and it ran fine. I gave it one more try tonight for stage 2 and it did the same thing. Just one try to start it. When I went BACK to stage 1 it did the same as stage 2 did. I've been emailing and their first suggestion was add an intake??? It ran fine all day today until I went to 2 and back. Any ideas?
Thankfully I have a spare vehicle..
 

·
Registered
Joined
·
696 Posts
I have a '19 performance pack and I've been running Cobb stage 1 for a few thousand miles. When I got my CVF intercooler (cobb said it'd be ok) installed, I drove home on stage 1. I tuned it to stage 2 and when I started it up, it idled rough and died. I tuned back to 1 last night and it ran fine. I gave it one more try tonight for stage 2 and it did the same thing. Just one try to start it. When I went BACK to stage 1 it did the same as stage 2 did. I've been emailing and their first suggestion was add an intake??? It ran fine all day today until I went to 2 and back. Any ideas?
Thankfully I have a spare vehicle..
I think COBB includes their cold air package with the stage 2 build. They might also include their catback exhaust.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
CAI is part of their stage 2 package, but they said it'd be ok with a high flow drop in filter. They just couldn't guarantee power gains. Also said didn't have to use their intercooler. Stage 3 includes the exhaust, which I don't want.
My car won't idle is the problem, and they said: might try a CAI...
 

·
Registered
Joined
·
570 Posts
I think COBB includes their cold air package with the stage 2 build. They might also include their catback exhaust.
[/The Stage 2 Power Package for the Mustang EcoBoost is the best second level for the Ecoboost powered vehicle. During exhaustive testing, the COBB engineers found that heat, not necessarily airflow, was the biggest restriction to power on the platform. As such, they married a larger COBB Front Mount Intercooler to our 3″ mandrel bent aluminum intake kit. This setup cools temps as much as 100 degrees and produces significant power. Everything is tuned right out of the box with the Accessport and Stage 2 Off the Shelf maps!
 

·
Registered
Joined
·
570 Posts
I have a '19 performance pack and I've been running Cobb stage 1 for a few thousand miles. When I got my CVF intercooler (cobb said it'd be ok) installed, I drove home on stage 1. I tuned it to stage 2 and when I started it up, it idled rough and died. I tuned back to 1 last night and it ran fine. I gave it one more try tonight for stage 2 and it did the same thing. Just one try to start it. When I went BACK to stage 1 it did the same as stage 2 did. I've been emailing and their first suggestion was add an intake??? It ran fine all day today until I went to 2 and back. Any ideas?
Thankfully I have a spare vehicle..
Go back through and check everything you touched while installing the intercooler, especially the IC piping.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
I've narrowed it down to the throttle body. When I open the door and push the clutch in, it starts buzzing and then it stops. It does this at the same rate as the rough idle. Idles at 1k then drops, several times and then it dies. What about disconnecting the battery? I've tuned to stock now. This sucks
 

·
Registered
Joined
·
570 Posts
I've narrowed it down to the throttle body. When I open the door and push the clutch in, it starts buzzing and then it stops. It does this at the same rate as the rough idle. Idles at 1k then drops, several times and then it dies. What about disconnecting the battery? I've tuned to stock now. This sucks
Don’t know if a reset will work, I would hook a scanner up to the car and monitor the TB voltage and other parameters, to nail down exactly what’s going on though. from your description it could be the TB is faulty.
It’s a 19 PP so it’s still got a warranty, why not take it to the dealer?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
I am throwing three codes, PO600 serial communications link, PO60C internal control module main processor performance, PO068A ECM/PCM power relay de-energized too early. Anyone have a clue what's up? . . .Probably going to dealer tomorrow
 

·
Registered
Joined
·
5 Posts
good luck. they might void the warranty though because the ECU was flashed.
Following though because i just tuned mine today. Curious to what the dealer says.
 

·
Registered
Joined
·
110 Posts
Watching this, I have a CVF intercooler and Roush CAI. Just bought the COBB V3.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Unhooked the battery to no avail. Cobb said hook a battery charger up and tune it. That's coming next after I get off work..will report back. Oh, they also said the ECU is okay if it's responding
 

·
Registered
Joined
·
202 Posts
You should have no issues running the stage 2 tune with the mods that you have. You definitely have something else going on with the car, isn't cobb support for the 18+ still fairly new? Makes me wonder if they still have some gremlins to work out with the new PCM's
 

·
Registered
Joined
·
570 Posts
Unhooked the battery to no avail. Cobb said hook a battery charger up and tune it. That's coming next after I get off work..will report back. Oh, they also said the ECU is okay if it's responding
This is a very real thing with today’s cars. If the computers, sensors, etc aren’t getting exactly what they need voltage wise, they’ll act all crazy. You may want to test your battery and charging system to make sure it’s up to the task, load test and check for AC voltage.
 

·
Registered
Joined
·
127 Posts
Try downloading the tunes from Cobb and loading them on the Accessport again. I was getting the same codes when I was having issues with a botched Cobb firmware update a while back that was causing the tune to not fully load on the car, same symptoms too. Also try to get Cobb to roll your firmware back if they are willing, just to see if that works.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #18
Ok, after having the access Port uninstalled for a few days, I tried it one more time. Straight to stage 2 93oct. And it worked. No issues whatsoever. I have no idea what the deal was. I always follow the directions when tuning. But stage two rocks compared to stock. Feels great 👍
 
1 - 18 of 18 Posts
Top