Ford Mustang Ecoboost Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello,

I recently installed a Turbosmart Dual Port BOV and it seems to cause flutter when letting off of the throttle at lower boost. It blows off fine at high boost. Does anyone else have this problem?

The only other mods I have done are:

Ford Performance CAI w/Tune.

Thanks for any help in this matter!

 

·
Registered
Joined
·
138 Posts
It's normal for the TS dual port valve to flutter at low boost. It's not a problem and part of normal operation of the valve. I've been told the dynamics of the super fast spoiling turbo cause it. Even my HKS valve flutters a little bit at low Boost.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Ok the TS BOV is off and stock setup back on. I think it runs just as good if not better. I am hearing a weird noise though. When I rev up and it goes back to idle, shortly after it sits at idle I hear a soft thud. Not sure what that is but it wasn't there before.
 

·
Registered
Joined
·
643 Posts
Ok the TS BOV is off and stock setup back on. I think it runs just as good if not better. I am hearing a weird noise though. When I rev up and it goes back to idle, shortly after it sits at idle I hear a soft thud. Not sure what that is but it wasn't there before.
Maybe it was there but now you can hear it due to other mods, such as an intake? The thud could be the valve closing against the charge pipe flange.
 

·
Registered
Joined
·
4 Posts
Quick question. If I do decide to get rid of the TurboSmart and get the GFB DV+, how difficult will it be to reinstall the stock bypass? Also, when taking the PCV valve off to put the vacuum line in, the small red clamp on the end had snapped. Can that just be picked up at any autopart hardware store?

Thanks,
Chris
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top